Adaptable CA prerequisites

Before you configure the Adaptable CA template and certificate object settings in Trust Protection Platform, you must have done the following:

  • Review the Adaptable Flow design to understand where you want the custom logic to be applied.
  • To work effectively with a Venafi Adaptable Driver, you must have some working knowledge of PowerShell scripting, or you must have equivalent experience with a scripting language similar to PowerShell.

  • Install Windows PowerShell 3.0 or later.
  • Install .NET 4.7.2 or later.
  • (Conditional) If your Adaptable script requires access to the Venafi Web SDK, you'll need to do the following:
    • Create an API Application Integration that's specific to your script. This is a required step in which you register your application with Trust Protection Platform. For more information, see Integrating other systems with Venafi products.

      TIP  When you configure your Adaptable object, you'll be required to specify the application ID you gave to your API Application Integration.

    • If you don't already have one, create a Username credential that has been associated with a service account that has permissions to the API application. See Creating user name or password credentials and Configuring the Adaptable Log Channel object.

What's next?

After you've completed the Adaptable CA prerequisites, see Configuring the Adaptable CA object.

To set up an Adaptable CA for CodeSign Protect, see Create an Adaptable CA template

Related Topics Link IconRelated Topics